PostgreSQL problem

I had to recently reinstall Win10 which required me to reinstall DAZ. I didn't think to check my purchased products for a Studio installer so I ended up being forced to install DAZCentral. I found it horribly buggy; the only thing it installed without cutting out multiple times was Studio itself. Trying to install a single item at a time out of my 5400+ product collection took several tries for each item. I gave up and uninstalled it; then found an old installer for DIM and started over. Now for some reason every time I open DIM or Studio I get an error message saying it can't "find" PostgreSQL. I have to reinstall it every time I load DIM so I know it's installed; the question seems to be where is it expecting to find it so it stops freaking out? I tried putting a copy where I thought it would go in DazCentral but it looks like I put it in the wrong place. I get legitimate answers from you guys far faster than DAZ Help nowadays so I'm asking here. Thanks in advance.

Comments

  • Canm't find or can't establish a connection?

  • edited February 24

    Can't establish a connection I believe.

     

    I used my GOOGLE-fu and discovered this post: https://helpdaz.zendesk.com/hc/en-us/articles/207812393-PostgreSQL-Connection-Error-and-No-Smart-Content which shows exactly the error I'm getting. Checking my firewall I don't see DAZ included in the listings nor do I know where to find it so I can add it.

    DIM keeps putting it in my download list every time I open DIM.

    Post edited by wickedprince3d_fd273b40ac on
  • ShelLuserShelLuser Posts: 375
    Maybe try again with an up to date DIM? If you check the commons forum you'll no notice a pinned thread about DIM with a link to download the latest version.
  • 1.4.0.67 is the version I have; as far as I can tell that is the newest version.

  • ShelLuserShelLuser Posts: 375

    Ok....  The above post was from my phone, let's get more serious.

    • Fire up DS, wait for that error message, then check your task manager (press: control + shift + escape).
    • Expand the DS process entry (see screenshot) and make sure it lists 'PostgreSQL Server'.

    If it does then you got a connectionion issue. The cause of that could be various. If you never messed with your DS configuration (or the PSQL config) then I'd assume that there's a firewall blocking the connection. A far fetched theory, but not totally impossible.

    If you don't see any psql entries then I'd suspect that something went wrong with the installation procedure.

    Hopefully we can take it from here.

  • edited February 24

    I checked my firewall settings and I couldn't find anything in the list of allowed apps that look like DIM, DAZ, DAZ studio, or PostgreSQL or anything along those lines that was allowed. I couldn't even find them as listed apps that were being refused. I tried to create an exception for PostgreSQL but I'm not sure if I did it properly.  I don't see a screenshot btw. I should also mention that the only thing I changed was switching the link of where it's installing stuff back to where DIM installs instead of Central. Following the suggestion of the link I found above I tried changing the CMS Settings port but when I found the port that DIM is using in it's settings I reset it to that.

    Post edited by wickedprince3d_fd273b40ac on
  • edited February 25

    Nothing I've tried has worked. DIM still insists I need to install PostgreSQL every time I load it and Studio gives me the error message noted in the above post about not getting a valid connection to PostgreSQL every time I start it.

     

    Ok: ShelLuser - I did what you suggested. The expanded view from Task Manager and it does not show PostgreSQL server. To me based on that previous QA posting here it sounds like it's a firewall issue since I can't find anything in my firewall permissions. I'm going to try shutting my firewall down temporarily to see if that's the case.

    Post edited by wickedprince3d_fd273b40ac on
  • edited February 25

    Ok I just tried this: Shut off Firewall for Domain, Public, and Private networks; uninstalled PostgreSQL; rebooted computer; reinstalled PostgreSQL and same problem with Studio with firewall still OFF as Win10 very definitely reminded me. So that suggests it's NOT the firewall after all.

    Post edited by wickedprince3d_fd273b40ac on
  • edited February 25

    Ok, thanks to a friend I found it; DAZ was pointing to the wrong location for where PostgreSQL was, once we got that straightened out everything seems to be working right as far as Studio is concerned. Thank you to those who responded.

    Post edited by wickedprince3d_fd273b40ac on
Sign In or Register to comment.