DAZ closes whenever Iray is invoked

jrlaudiojrlaudio Posts: 43

Hello,

I just installed the latest release 4.16.0.3 Pro Edition. I also installed the latest version of nVidia Studio driver. The computer in question is an older workstation HP Z820 dual Xeon (E5-2697 v2), 256Gb ECC RAM. GPU is a 3090. I have not updated my main machines yet, I have two other workstations (Z840).

I have never had DAZ crash with prior versions, ever. Been using it for many years. The current problem is whenever I use Iray, either in viewport or just normal render, DAZ just quits. No system error message. I tried going back to the previous GPU driver, and still no joy. I used a third party driver removal tool (DDU) to clear eveything out before installing any drivers. I uninstalled DAZ via DIM, restarted, installed DAZ again. No joy with both GPU drivers, so I think the issue is with the DAZ API for Iray on this new version on my particular machine.

I even tried a new scene using the basic G8M figure, click render or chose Iray in viewport and DAZ shuts down. The log file shows that when it begins to load figure images, it just stops. No code or error, the list just ends after a few images load. Now it's not like I have memory issues, it's a 3090, and the system has over 230Gb free physical memory available. I'm not doing anything tweaky with either the system or the OS. No OC or anything with virtual memory, or things like that. Everything, hardware and software, are at defaults.

I'm at a loss and can't do anything right now. Where do I begin? I've never had issues with DAZ or Iray before, so I don't even know what information anyone needs to get started. There's nothing in the log file, been through every line from starting Daz; no warnings or errors. It just stops once it begins loading image files.

Thanks in advance.

 

Post edited by jrlaudio on

Comments

  • Will it render a simple sphere primitie?

  • jrlaudiojrlaudio Posts: 43
    edited November 2021

    I just tried that. Yes ... but as soon as I add a texture to the diffuse only and render, it shuts down. It's something gone wonky with how the API is handling texture images.

    I do draw from a NAS via Ethernet cable which is where my content files are located. But I never had a problem with this previously. I checked the network and it's operating nominally. DAZ is also pointing to the right folders on the NAS as well, since I have no issues with GL or PBR viewport. Just Iray.

    I haven't tried queing to Iray Server, since that machine is on a separate secured network. I have a feeling it would not do the same thing as rendering through the DAZ API locally versus the Iray Server bridge.

    Post edited by jrlaudio on
  • jrlaudiojrlaudio Posts: 43
    edited November 2021

    OK ... I just put that texture image on my local hardrive to see if it was an issue with the NAS. Same thing happened, shut down as soon as I hit render. The whole prgram just shuts down, like when you exit DAZ. Nothing in the log to indicate any error. I'm at a loss.

    Post edited by jrlaudio on
  • What image format are you using?

  • jrlaudiojrlaudio Posts: 43
    edited November 2021

    .jpg. It's an MDL that comes with DAZ. Actually it the "Mahogany Floorboards" diffuse texture from the nvidia MDL examples.

    Post edited by jrlaudio on
  • I just tried loading the entire MDL onto the sphere primitive. Same problem. Shut down.

  • jrlaudiojrlaudio Posts: 43
    edited November 2021

    PerttiA said:

    There has been problems with those

    https://www.daz3d.com/forums/discussion/comment/7110871/#Comment_7110871
    https://www.daz3d.com/forums/discussion/comment/7112911/#Comment_7112911

    No ... it's not MDL materials it's all of them, DAZ content, poser content, everything that worked fine for me before. New figures that came out after the new version of DAZ included. Nothing works. DAZ just shuts down once it starts loading images into Iray. My paths are all standard.

    If it's just geometry with no mateirals, it renders. As soon as any material images are being sent to Iray, DAZ just shut down.

    Here's the last 20 or so lines of the log file.  I tried loading the new "Lincoln" figure with a pretty standard HDRi iamge. As soon a the image files began to load it just stopped and shut down.

     

    2021-11-29 12:01:23.001 Prepare asset load (merge): /Light Presets/DimensionTheory/Iradiance Pro-Series HDRIs/Photo Studio/DTHPS - Photo Studio Backdrop Soft - 8k.duf
    2021-11-29 12:01:23.001 Locking viewport redraw...
    2021-11-29 12:01:23.001 Viewport redraw locked.
    2021-11-29 12:01:23.172 Native format content directories: 4
    2021-11-29 12:01:23.172 Poser format content directories: 2
    2021-11-29 12:01:23.172 Other import format content directories: 0
    2021-11-29 12:01:23.172 Begin asset load (merge): /Light Presets/DimensionTheory/Iradiance Pro-Series HDRIs/Photo Studio/DTHPS - Photo Studio Backdrop Soft - 8k.duf
    2021-11-29 12:01:23.174 Determining missing assets...
    2021-11-29 12:01:23.178 Setting textures...
    2021-11-29 12:01:23.178 Processing scene data...
    2021-11-29 12:01:23.180 Finalizing scene data...
    2021-11-29 12:01:23.180 Finished asset load (merge): 0m 0.8s - /Light Presets/DimensionTheory/Iradiance Pro-Series HDRIs/Photo Studio/DTHPS - Photo Studio Backdrop Soft - 8k.duf
    2021-11-29 12:01:30.589 Loaded image: DTHPS-PhotoStudioBackdropSoft-8k.exr
    2021-11-29 12:01:31.315 Unlocking viewport redraw...
    2021-11-29 12:01:31.315 Viewport redraw unlocked.
    2021-11-29 12:01:50.832 Iray [INFO] - IMAGE:IO ::   1.0   IMAGE  io   info : Loading image "\\MYCLOUDPR4100\John's_Stuff\My DAZ 3D Library\Runtime\Textures\3DUniverse\Genesis8Male\Lincoln\Figure\3duG8MLincoln_DF_Face_1001.jpg", pixel type "Rgb", 4096x4096x1 pixels, 1 miplevel.
    2021-11-29 12:01:50.906 Iray [INFO] - IMAGE:IO ::   1.0   IMAGE  io   info : Loading image "\\MYCLOUDPR4100\John's_Stuff\My DAZ 3D Library\Runtime\Textures\3DUniverse\Genesis8Male\Lincoln\Figure\3duG8MLincoln_SP_Face_1001.jpg", pixel type "Rgb", 4096x4096x1 pixels, 1 miplevel.

     

     

    As you can see I loaded the HDRi and then evoked Iray in the viewport. It loaded the first two images for the figure from my NAS then it quits. The last line above is the last line in log file. I used the "Lincoln"  figure since it was the most recent content from DAZ I have, but it happens on everything, even Basic G8M. It had no problem with the big .exr image, but once it started loading the figure images.... Remember, 3090 and 256Gb system RAM so it's not a memory deficiency. I use a NAS instead of the local drives because I literally have a dozen or so Tb's of content, both DAZ stuff and custom stuff created in-house. I need to be able to use it. Clearly DAZ is seeing files where it's targeted, but it won't create the correct scene files for Iray anymore.

    Post edited by jrlaudio on
  • I just brought up Maya/V-ray which I also just updated. I set V-Ray to render on the GPU and it went fine with no issues. And V-Ray prefers to run on CPU. Go figure.

  • The last line in the log isn't necessarily relevant as the log is cached and written when it won't interfere with other actions, so it may not have reached the crash-causing stage there.

Sign In or Register to comment.