OSX/XCode help

shoei321shoei321 Posts: 112
edited December 1969 in Daz SDK Developer Discussion

I'm able to build DazStudio plugins without issue in Windows/VisualStudio, but am struggling to get OSX and XCode to compile the same plugin code. I've followed the OSX instructions included in the SDK, but I'm afraid they may be a bit out of date.

My setup is OSX 10.10.3 (latest), and XCode 6.3.2. I've configured the XCode project according to the SDK instructions (MacOSX10.5.sdk Target SDK). When I compile I get a QT-related error :

QList.h lines 184 and 231: Reference to 'random_access_iterator_tag' is ambiguous

Can someone get me pointed in the right direction? Or ideally, can someone publish a preconfigured template XCode project, similar to what the SDK includes for each of the samples for Visual Studio?

Thanks!

Comments

  • mattiascibienmattiascibien Posts: 140
    edited September 2015

    A google search led me to problems similar to yours in other things. I think that the Qt version used by Daz SDK is somehow old to use with relatively new compilers (. 

    Unofrtunately I can be no more help because I do not know MacOS as a dev environment. Anyway I will be glad to know this since I will probabiliy go multiplatform with my plugins.

    # Xcode 6.3.2 (6D2105)
    Apple LLVM version 6.1.0 (clang-602.0.53) (based on LLVM 3.6.0svn)
    Target: x86_64-apple-darwin14.3.0
    Thread model: posix

    Post edited by mattiascibien on
  • I never had any luck getting the latest XCode to work so I'm using 3.2.6 in a OSX Lion Virtual Machine to compile DAZ Studio plug-ins. I can share my project file if it helps.

  • Eric, that would be much appreciated.   I'm not sure if you can post non image files here -- you might try using a file hosting site and post the link here so that others can access it as well. 

    To the Daz folks -- having a reference XCode project in the SDK and a bit of guidance around environment configuration would be incredibly helpful.  

     

     

  • EsemwyEsemwy Posts: 575

    You need to use an older version of the SDK. To get those installed in the current Xcode, I used XcodeLegacy, which is just a shell script, but installs all the old SDKs where Xcode can find them. I've been able to compile plugins using 10.6 through 10.9 compatibility. 

  • Here's a link to my project file. Hope it helps.

    https://www.dropbox.com/s/imrrtkb5dw1oxpu/project.pbxproj?dl=0

    Regards,

  • Esemwy said:

    You need to use an older version of the SDK. To get those installed in the current Xcode, I used XcodeLegacy, which is just a shell script, but installs all the old SDKs where Xcode can find them. I've been able to compile plugins using 10.6 through 10.9 compatibility. 

    Oh that looks very handy.

Sign In or Register to comment.