'Renderer not found' when running DAZ from external application

I have an external program, which calls DAZ via the SDK.

Basically the flow is:
Start up DAZ studio
Load up various objects and pose presets
Do a series of renderings with various objects turned on and off
Exit DAZ studio

This worked fine with DAZ < 4.5 - Unfortunately this is no longer the case.

Each render is done by the call:
dzApp->getRenderMgr()->doRender( renderOptions );

which now just gives me a msg box saying: "Unable to render, no rendering engine available"

The call to

Showed that I have a grand total of 0 available renderers - at least the msg box makes sense :)

So the question is:

How do I get access to a valid 3Delight renderer when I start DAZ studio via an external program?

Any input/help will be greatly appreciated.



  • Richard HaseltineRichard Haseltine Posts: 80,481
    edited December 1969

    I assume you can render directly, with cmd/ctrl-r?

  • edited December 1969

    If I start the program normally - yes

    Running via app->run(DzApp::FullInterface) - no (same error msg)

  • Richard HaseltineRichard Haseltine Posts: 80,481
    edited December 1969

    Make a bug report then, please.

  • edited December 1969


    This only happens in the 64 bit version. 32 bit works fine.

    I'll submit a bug report when time permits.

  • I have similar error. When I clic render I received "no renderer" and I have no option in render setting menu... I can't make animation... And when render work the picture is small same if I use full screen mode with ctrl+r .... Please help me all work in the past just today bug....
Sign In or Register to comment.