The Missed It By That Much to Get a Bacon Steak Sandwich Complaint Thread

12223252728100

Comments

  • ps1borgps1borg Posts: 12,776
    edited December 1969

    chohole said:
    Happy Birthday to Attic Anne when she arrives.

    +1 :)

    HBDA.jpg
    1500 x 1500 - 184K
  • SerpentSerpent Posts: 4,075
    edited December 1969

    DanaTA said:

    is fun to use funny names for variables? :lol: like myFruitLoops tee hee myFoobar

    It may be funny to you, but I pity the person who may need to take over your code. :smirk:

    Dana

    Let me tell you a story of the early days of programming...

    Since in those wild and woolly days there were no real rules as to variable naming, people used whatever seemed appropriate at the time. At MIT, they came up with the idea of a "meta-syntactic variable":

    https://en.wikipedia.org/wiki/Metasyntactic_variable

    ..so it was pretty standard to discover code with variables actually called foo, bar, and baz. Loop counters were usually loopy, looper, and in one FORTRAN program I worked on I found the variable nWhereIAm. :blank:

    Nowadays, there are several more formal approaches that are supposed to help make code "understandable", like making the leading part of the variable indicate its type, as in n for a number (nTempCounter), b for a byte (bFlag), and p or ptr to indicate a pointer (pFoo or ptrFoo). There's also so-called CamelCase, supposedly making variables like nthisisatempcounter easier to read as nThisIsATempCounter.

    Throw-asway counters, etc. always seemed to be called i, j, or k. :blank: Soooo much easier to type 1 letter for a variable that is only there to count up or down.

    Thus endeth the lesson. :P

  • ps1borgps1borg Posts: 12,776
    edited June 2015

    TroutFace said:
    DanaTA said:

    is fun to use funny names for variables? :lol: like myFruitLoops tee hee myFoobar

    It may be funny to you, but I pity the person who may need to take over your code. :smirk:

    Dana

    Let me tell you a story of the early days of programming...

    Since in those wild and woolly days there were no real rules as to variable naming, people used whatever seemed appropriate at the time. At MIT, they came up with the idea of a "meta-syntactic variable":

    https://en.wikipedia.org/wiki/Metasyntactic_variable

    ..so it was pretty standard to discover code with variables actually called foo, bar, and baz. Loop counters were usually loopy, looper, and in one FORTRAN program I worked on I found the variable nWhereIAm. :blank:

    Nowadays, there are several more formal approaches that are supposed to help make code "understandable", like making the leading part of the variable indicate its type, as in n for a number (nTempCounter), b for a byte (bFlag), and p or ptr to indicate a pointer (pFoo or ptrFoo). There's also so-called CamelCase, supposedly making variables like nthisisatempcounter easier to read as nThisIsATempCounter.

    Throw-asway counters, etc. always seemed to be called i, j, or k. :blank: Soooo much easier to type 1 letter for a variable that is only there to count up or down.

    Thus endeth the lesson. :P

    Just as well, you couldn't do robotics at MIT back in the day without rewriting 1000 lines of code :lol:

    Post edited by ps1borg on
  • SerpentSerpent Posts: 4,075
    edited December 1969

    Happy Birthday Annie!

    Have a wonderful day! :cheese: :cheese:

  • SerpentSerpent Posts: 4,075
    edited December 1969

    ps1borg said:
    TroutFace said:
    DanaTA said:

    is fun to use funny names for variables? :lol: like myFruitLoops tee hee myFoobar

    It may be funny to you, but I pity the person who may need to take over your code. :smirk:

    Dana

    Let me tell you a story of the early days of programming...

    Since in those wild and woolly days there were no real rules as to variable naming, people used whatever seemed appropriate at the time. At MIT, they came up with the idea of a "meta-syntactic variable":

    https://en.wikipedia.org/wiki/Metasyntactic_variable

    ..so it was pretty standard to discover code with variables actually called foo, bar, and baz. Loop counters were usually loopy, looper, and in one FORTRAN program I worked on I found the variable nWhereIAm. :blank:

    Nowadays, there are several more formal approaches that are supposed to help make code "understandable", like making the leading part of the variable indicate its type, as in n for a number (nTempCounter), b for a byte (bFlag), and p or ptr to indicate a pointer (pFoo or ptrFoo). There's also so-called CamelCase, supposedly making variables like nthisisatempcounter easier to read as nThisIsATempCounter.

    Throw-asway counters, etc. always seemed to be called i, j, or k. :blank: Soooo much easier to type 1 letter for a variable that is only there to count up or down.

    Thus endeth the lesson. :P

    Just as well, you couldn't do robotics at MIT back in the day without rewriting 1000 lines of code :lol:

    I almost had a chance to go to MIT.. my boss at the time I got out of high school was an alumni and told me he could get me in if I wanted, that it would be perfect for me.. but I had a girlfriend and a healthy income so I passed. :down:

    On my top 10 list of "Stupid Things I've Done With My Life". :down:

  • ps1borgps1borg Posts: 12,776
    edited December 1969

    TroutFace said:
    ps1borg said:
    TroutFace said:
    DanaTA said:

    is fun to use funny names for variables? :lol: like myFruitLoops tee hee myFoobar

    It may be funny to you, but I pity the person who may need to take over your code. :smirk:

    Dana

    Let me tell you a story of the early days of programming...

    Since in those wild and woolly days there were no real rules as to variable naming, people used whatever seemed appropriate at the time. At MIT, they came up with the idea of a "meta-syntactic variable":

    https://en.wikipedia.org/wiki/Metasyntactic_variable

    ..so it was pretty standard to discover code with variables actually called foo, bar, and baz. Loop counters were usually loopy, looper, and in one FORTRAN program I worked on I found the variable nWhereIAm. :blank:

    Nowadays, there are several more formal approaches that are supposed to help make code "understandable", like making the leading part of the variable indicate its type, as in n for a number (nTempCounter), b for a byte (bFlag), and p or ptr to indicate a pointer (pFoo or ptrFoo). There's also so-called CamelCase, supposedly making variables like nthisisatempcounter easier to read as nThisIsATempCounter.

    Throw-asway counters, etc. always seemed to be called i, j, or k. :blank: Soooo much easier to type 1 letter for a variable that is only there to count up or down.

    Thus endeth the lesson. :P

    Just as well, you couldn't do robotics at MIT back in the day without rewriting 1000 lines of code :lol:

    I almost had a chance to go to MIT.. my boss at the time I got out of high school was an alumni and told me he could get me in if I wanted, that it would be perfect for me.. but I had a girlfriend and a healthy income so I passed. :down:

    On my top 10 list of "Stupid Things I've Done With My Life". :down:

    I totally fluked it, planets just lined up the right way for a while and got a scholarship grant this end, no idea why fortune's wheel turned that way but wow ! :lol:

  • SerpentSerpent Posts: 4,075
    edited December 1969

    ps1borg said:
    TroutFace said:
    ps1borg said:
    TroutFace said:
    DanaTA said:

    is fun to use funny names for variables? :lol: like myFruitLoops tee hee myFoobar

    It may be funny to you, but I pity the person who may need to take over your code. :smirk:

    Dana

    Let me tell you a story of the early days of programming...

    Since in those wild and woolly days there were no real rules as to variable naming, people used whatever seemed appropriate at the time. At MIT, they came up with the idea of a "meta-syntactic variable":

    https://en.wikipedia.org/wiki/Metasyntactic_variable

    ..so it was pretty standard to discover code with variables actually called foo, bar, and baz. Loop counters were usually loopy, looper, and in one FORTRAN program I worked on I found the variable nWhereIAm. :blank:

    Nowadays, there are several more formal approaches that are supposed to help make code "understandable", like making the leading part of the variable indicate its type, as in n for a number (nTempCounter), b for a byte (bFlag), and p or ptr to indicate a pointer (pFoo or ptrFoo). There's also so-called CamelCase, supposedly making variables like nthisisatempcounter easier to read as nThisIsATempCounter.

    Throw-asway counters, etc. always seemed to be called i, j, or k. :blank: Soooo much easier to type 1 letter for a variable that is only there to count up or down.

    Thus endeth the lesson. :P

    Just as well, you couldn't do robotics at MIT back in the day without rewriting 1000 lines of code :lol:

    I almost had a chance to go to MIT.. my boss at the time I got out of high school was an alumni and told me he could get me in if I wanted, that it would be perfect for me.. but I had a girlfriend and a healthy income so I passed. :down:

    On my top 10 list of "Stupid Things I've Done With My Life". :down:

    I totally fluked it, planets just lined up the right way for a while and got a scholarship grant this end, no idea why fortune's wheel turned that way but wow ! :lol:

    Strange things happen!! :ahhh: :ahhh:

  • MistaraMistara Posts: 38,675
    edited December 1969

    tjohn said:
    Code only you can understand = job security :cheese:


    :lol:

  • MistaraMistara Posts: 38,675
    edited December 1969

    ps1borg said:
    These have to be the most useless things I've made this year, oh well at least it has been relaxing: about 6 hours worth :)

    1804 8LB cannon and cassion


    iz heavy artillery :)

  • MistaraMistara Posts: 38,675
    edited December 1969

    AtticAnne said:
    Are you speaking Computer again, Misty?

    This is where I am:

    x = 0
    ans = 0
    itersLeft = x
    while (itersLeft ! = 0)
    ans = ans + 1

    not finished

    My A/C decided to quit so I came to the YMCA to use their WiFi and A/C while doing some of my homework.


    Happy Birthday!

    PARTY :)

  • DanaTADanaTA Posts: 13,207
    edited December 1969

    TroutFace said:
    DanaTA said:

    is fun to use funny names for variables? :lol: like myFruitLoops tee hee myFoobar

    It may be funny to you, but I pity the person who may need to take over your code. :smirk:

    Dana

    Let me tell you a story of the early days of programming...

    Since in those wild and woolly days there were no real rules as to variable naming, people used whatever seemed appropriate at the time. At MIT, they came up with the idea of a "meta-syntactic variable":

    https://en.wikipedia.org/wiki/Metasyntactic_variable

    ..so it was pretty standard to discover code with variables actually called foo, bar, and baz. Loop counters were usually loopy, looper, and in one FORTRAN program I worked on I found the variable nWhereIAm. :blank:

    Nowadays, there are several more formal approaches that are supposed to help make code "understandable", like making the leading part of the variable indicate its type, as in n for a number (nTempCounter), b for a byte (bFlag), and p or ptr to indicate a pointer (pFoo or ptrFoo). There's also so-called CamelCase, supposedly making variables like nthisisatempcounter easier to read as nThisIsATempCounter.

    Throw-asway counters, etc. always seemed to be called i, j, or k. :blank: Soooo much easier to type 1 letter for a variable that is only there to count up or down.

    Thus endeth the lesson. :P

    Oh, I know. I've seen Foo used. And those single letter counters? Yeah. Two different loops in the same function, with the same counter variable name. So...you get an error: i is out of range. Which i is it? What do I say to that? Foo! :lol:

    Dana

  • DanaTADanaTA Posts: 13,207
    edited December 1969

    Happy Birthday, Attic Anne!

    Dana

  • LeatherGryphonLeatherGryphon Posts: 11,505
    edited June 2015

    DanaTA said:
    TroutFace said:
    DanaTA said:

    is fun to use funny names for variables? :lol: like myFruitLoops tee hee myFoobar

    It may be funny to you, but I pity the person who may need to take over your code. :smirk:

    Dana

    Let me tell you a story of the early days of programming...

    Since in those wild and woolly days there were no real rules as to variable naming, people used whatever seemed appropriate at the time. At MIT, they came up with the idea of a "meta-syntactic variable":

    https://en.wikipedia.org/wiki/Metasyntactic_variable

    ..so it was pretty standard to discover code with variables actually called foo, bar, and baz. Loop counters were usually loopy, looper, and in one FORTRAN program I worked on I found the variable nWhereIAm. :blank:

    Nowadays, there are several more formal approaches that are supposed to help make code "understandable", like making the leading part of the variable indicate its type, as in n for a number (nTempCounter), b for a byte (bFlag), and p or ptr to indicate a pointer (pFoo or ptrFoo). There's also so-called CamelCase, supposedly making variables like nthisisatempcounter easier to read as nThisIsATempCounter.

    Throw-asway counters, etc. always seemed to be called i, j, or k. :blank: Soooo much easier to type 1 letter for a variable that is only there to count up or down.

    Thus endeth the lesson. :P

    Oh, I know. I've seen Foo used. And those single letter counters? Yeah. Two different loops in the same function, with the same counter variable name. So...you get an error: i is out of range. Which i is it? What do I say to that? Foo! :lol:

    Dana

    At the other end of the spectrum was COBOL with half-line long variable names. :-S

    And eventually straight from god came the divine messenger "C" which made it possible to heiracherize your code so well that it could be compressed into a solid block of characters many pages long and spawn contests to create the most undecipherable program. %-P

    And of course we mustn't forget about the shell scripts "sh", and "csh" and their progeny which incorporated the concept of "Regular Expressions" and created the concept of a "UNIX Guru" who could cast those arcane magical spells about like fireworks from their fingertips. :coolgrin:

    Post edited by LeatherGryphon on
  • SkirikiSkiriki Posts: 4,975
    edited December 1969

    Not a complaint!

    Opposite of it!

    Happy for my friends!

    PS: Happy birthday, Anne!

    kisskiss.gif
    500 x 352 - 1M
  • Sfariah DSfariah D Posts: 26,259
    edited December 1969

    happy birthday to Anne!

  • fixmypcmikefixmypcmike Posts: 19,583
    edited December 1969

    My favorite is APL, the only programming language where back-spacing and typing a second character on top of the first is meaningful.

  • TJohnTJohn Posts: 11,095
    edited December 1969

    I like PIE.

    PiesIHaveEaten.png
    523 x 349 - 302K
  • ps1borgps1borg Posts: 12,776
    edited December 1969

    Morning. Work on Saturday ughhh :lol: And two jumpers cool, altho overcast blew away overnight and it looks like sun is on the way any time nao *waits* :lol:

  • ps1borgps1borg Posts: 12,776
    edited December 1969

    tjohn said:
    I like PIE.

    My kinda calculation *wants* :)

  • MistaraMistara Posts: 38,675
    edited June 2015

    the great pizza pie thaz amore-ay :lol:


    is T G I F where da BEEEEEEER ?

    Post edited by Mistara on
  • DanaTADanaTA Posts: 13,207
    edited December 1969

    tjohn said:
    I like PIE.

    Nice pie chart!

    Dana

  • kyoto kidkyoto kid Posts: 41,040
    edited June 2015

    ...OK the good...

    Congratulations Annie for completing 74 consecutive trips (hope I got that right) around our central main sequence G type stellar primary.. if stretched out in a straight line you have travelled 43,217,429,014 miles which would put you further into interstellar space than either Tjohn, or I (not sure about our squirrely friend with the whip).

    Post edited by kyoto kid on
  • kyoto kidkyoto kid Posts: 41,040
    edited December 1969

    ...the bad

    Mid month payment still hasn't arrived.

  • kyoto kidkyoto kid Posts: 41,040
    edited December 1969

    ...and the ugly.

    As I have nothing in my bank account, looks like with Comcast three strikes and I'm out. Tried to go for another extension but they wo"said they couldn't do it so most likely my service will be cut off tonight at midnight.

  • kyoto kidkyoto kid Posts: 41,040
    edited June 2015

    tjohn said:
    I like PIE.

    ...my kind of pie chart.
    Post edited by kyoto kid on
  • kyoto kidkyoto kid Posts: 41,040
    edited December 1969

    ..one more "good'

    Picked up a couple zlotys so was actually able to go to an air conditioned pub for a couple three BEERS.as it hit 98° today.

    Have a little left over for tomorrw as it's supposed to reach 100° - 102°

    High on the Fourth next week will be 105°

    On hot days like this the Microwave is your friend. Warming up some of my taco filling and tortillas.for dinner.

  • atticanneatticanne Posts: 3,009
    edited December 1969

    To continue with the full example of my homework. After all, I did put "not finished" because that's all I had typed at that time. Foo has already come up in this class. BTW, the class is MIT 6.00.1.

    Capture_iterPDF.JPG
    632 x 378 - 32K
  • kyoto kidkyoto kid Posts: 41,040
    edited June 2015

    ...and the ugly pt. II:

    Been getting BSODs on the workstation again after over a year of trouble free operation.

    None of the diagnostic reports in the Event Viewer seem to make any sense as to helping me figure out what may be causing this.

    Post edited by kyoto kid on
  • fixmypcmikefixmypcmike Posts: 19,583
    edited December 1969

    Do you have all the numbers copied from the BSOD?

  • DanaTADanaTA Posts: 13,207
    edited December 1969

    AtticAnne said:
    To continue with the full example of my homework. After all, I did put "not finished" because that's all I had typed at that time. Foo has already come up in this class. BTW, the class is MIT 6.00.1.

    Is this the very old, "classic", BASIC? It's been a long time since I used that. It was in the first class I took in college in 1991, Introduction to Computers. A little of this, a little of that. (BASIC, WordPerfect for DOS, Lotus 123, DOS batch files) VB.NET is long removed from that, mutated and enhanced. It's not unrecognizable, but there's a lot that has been added, or modified, or beefed up.

    Even back then, the While had an End While I believe. Your print statements should be after the end of the loop. Have you tried to run that?

    Dana

This discussion has been closed.